• Новые темы в этом разделе публикуются автоматически при добавлении файла в менеджер ресурсов.
    Ручное создание новых тем невозможно.
Иконка ресурса

Мануал Авто-развертывание сервера L2 interlude через Docker (Ubuntu 18.04 - Тест)

Нет прав для скачивания
  • Автор темы Автор темы Hallow
  • Дата начала Дата начала

Hallow

Пляшущий с бубном
Местный
Сообщения
100
Розыгрыши
0
Репутация
159
Реакции
77
Баллы
213
Hallow добавил(а) новый ресурс:

Авто-развертывание сервера L2 interlude через Docker (Ubuntu 18.04 - Тест) - Готовый сервер Lineage 2 в Docker за 5 минут (Тест)

Авто-развертывание сервера L2 interlude через Docker (Ubuntu 18.04 - Тест)

Возможно сделаю инструкцию без докера позже.
Это были просто тесты, по этому гарантий дать не могу.
Сайт откуда взял инструкцию (он был для Windows) на poloman.pro, он уже не работает.
Изначально я запускал сервер Ubuntu 18.04 и работал он для тестов около года изредка…
после сервер сломался и никак не смог, но основном ПК починить, вот и сделал две тестовые установки на отдельном ПК, а раз оригинальной...

Узнать больше об этом ресурсе...
 

kick

Баллов: 51
За сообщение
Внешние доступы к бд лучше не открывать, а использовать к примеру портфорвард или скрыть за впн
 
Внешние доступы к бд лучше не открывать, а использовать к примеру портфорвард или скрыть за впн
Это точно, VPN бы вообще хотел поставить на всю self-hosted инфраструктуру - но ситуация с VPN усложнилась а сам живу в сельской местности в горах, и человек без пластиковой карты и даже виртуальной купить не могу... Варианты конечно есть. Но сложновато по своему...
Да и можно:
Код:
nano /srv/l2docker/docker-compose.yml
Код:
ports:  - "3306:3306"

Заменить на:
ports:
Код:
- "127.0.0.1:3306:3306"
Код:
docker-compose up -d db

Можно потом сделать SSH туннель если правильно помню:
Код:
ssh -L 3307:127.0.0.1:3306 [email protected].*.* -N
И в самом Navicat 127.0.0.1, порт 3307 не закрывая окно PoSh
Да и сам Navicat поддерживает туннель и PuTTY тоже.

Так же можно:
Код:
sudo apt update
Код:
sudo apt install ufw fail2ban -y

Создать:
Код:
sudo nano /etc/fail2ban/filter.d/l2auth.conf

Содержимое:
Код:
[Definition]
failregex = ^.*Authentication failed for user .* from IP <HOST>.*$
            ^.*Invalid login attempt from <HOST>.*$
ignoreregex =

Настройка:
Код:
sudo nano /etc/fail2ban/jail.local

Содержимое:
Код:
[l2-auth]
enabled = true
port = 2106
filter = l2auth
logpath = /var/lib/docker/containers/$(docker inspect -f '{{.Id}}' l2-authserver)/*-json.log
maxretry = 5
bantime = 600
findtime = 300
chain = DOCKER-USER
Можно и через named pipe но это уже переизбыток для тестового сервера да и помню абы да как бы.
И еще UFW:
Код:
sudo ufw allow 22/tcp           # SSH, чтобы не потерять доступ
sudo ufw allow 2106/tcp         # Authserver
sudo ufw allow 7777/tcp         # Gameserver
sudo ufw enable
 
Последнее редактирование:
Это точно, VPN бы вообще хотел поставить на всю self-hosted инфраструктуру - но ситуация с VPN усложнилась а сам живу в сельской местности в горах, и человек без пластиковой карты и даже виртуальной купить не могу... Варианты конечно есть. Но сложновато по своему...
Так он бесплатный. Я про openvpn, tailscale и ему подобное
 
к стати скачал OpenVPN да tailscale но совсем позабыл о них, уже не вспомню хотя кажется записал в ДокуВики... Но хотел сметить роутер Меркусис на микротик Hap-Light кажется, а вся Self-hosted работает у меня в Режиме APIPA который сбил тогда и причем понял когда настроил уже микротик и половина системы не запустилась... Вернул обратно едва едва APIPA и решил тогда не трогать уже ничего.

Но причины были и другие почему не стал настраивать VPN... Однако если тоже не записал в ДокуВики едва вспомню но в голове что крутилось Все стало платным... недоступным, нельзя скачать и т.п. вот и не возвращался даже к вопросу... Странно но как было.
 
Назад
Сверху Снизу